Jasper Ji

博观而约取,厚积而薄发。

Eclipse笔记

2021-04-14 06:43

为什么是Eclispe

最早接触Eclispe主要是用来开发Android应用,早期Android开发没有Android Studio,只能通过安装插件来开发。后来开发iOS后,Eclispe就用的少了,偶尔用来跑些简单的例子。后来做Java web,Eclispe又开始用了起来。

虽然很多人推荐IntelliJ IDEA,下载的试用了下,某些功能确实比Eclispe强大,但是Eclispe+Spring Tools,对目前的开发来说确实已经够用了,另外还是有点用不习惯,也没有Spring tools 这样的插件,所以干嘛花钱买个自己用不惯的东西呢?

自动补全

默认出现点号时才会出现自动补全的提示,不过可以设置,这里以Mac环境为例。

选择菜单Perferences->Java->Content Assist->Auto activation triggers for Java,默认为.,使用.abcdefghijklmnopqrstuvwsyzABCDEFGHIJKLMNOPQRSTUVWSYZ_替换,点击Ok。

常用插件

EasyShell,这个工具主要是可以快速在当前目录打开Shell以及打开当前的文件夹。

Maven 配置文件报错

Maven使用本地Jar包后pom.xml显示错误,实际上本地Jar包是可以加载的,但总是提示错误。

dependencies.dependency.systemPath’ for com.test:test:jar must specify an absolute path but is ${pom.basedir}/libs/test.jar

<dependency>
	<groupId>com.test</groupId>
	<artifactId>test</artifactId>
	<version>1.0</version>
	<scope>system</scope>
	<systemPath>${pom.basedir}/libs/test.jar</systemPath>
</dependency>

这个问题虽然不影响使用,但是老显示红叉,总感觉像去掉的。我原来使用Eclispe版本是2020-03 (4.15.0),没有这个问题。但是使用最新的Eclipse版本2021-03 (4.19.0)有这个问题,包括Spring ToolSuite 4也有这个问题,我把4.15.0到4.19.0版本下载几个对比后,终于发现4.16.0开始都有问题,最后发现4.16.0版本Preferences多了一个XMl(Wide Web Developer)项,把子项Validation & Resolution,Enable validation 禁用就没有了。

升级与不升级

如果现有环境稳定,那就最好不要升级。Eclispe好处是可以支持多个语言的开发,可以装一堆插件支持,但感觉只把它当作Java IDE就可以了,现在VS Code完全可以做其他语言的IDE。

之前的Eclispe很稳定,但一次插件的安装后,弹出需要更高版本的Eclispe,然后就无法启动了。一气之下,直接删除Eclispe,重新安装那些插件,结果发现2020-03 (4.15.0)下载的Spring Tools插件不能使用,发现Spring Tools 4已经出了,但是我当前这个版本无法使用。最后下载了Spring Tools官方出品的Eclispe整合版本Spring ToolSuite 4,就结果就出现了上面提到的Maven配置报错的问题,虽然问题解决了,但是还是提示插件安装也是要谨慎,可能升级不对就的折腾半天了。

Comments